Can't install puppetdb.

asked 2016-02-25 14:14:21 -0500

When I try to install the puppetdb-terminus yum package it failes depndency check with: Requires: Puppetdb-termini

from what I can tell this is a ruby package that we i need to pull from the Puppetdb source code. I've dowloade 4 versions of puppetdb source so far and none have the directory structury (puppet/lib/puppet) listed in the puppetlabs docs https://docs.puppetlabs.com/puppetdb/...puppetmaster.html in the "on platofoms without packages" section.

I can't utilize the repos so have to do the installation by hand. anyone know where I can get the files to utilize the solution here which is supposed to occur after unzipping the puppetdb source code.

"Run sudo cp -R puppet/lib/puppet/ /usr/lib/ruby/siteruby/1.8/puppet. Replace the second path with the path to your Puppet installation if you have installed it somewhere other than /usr/lib/ruby/siteruby. If you are using Puppet 4 or greater, replace the second path with the path to the ruby supplied by Puppet at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet."

edit retag flag offensive close merge delete