Ask Your Question
4

How do you change the runinterval

asked 2013-08-13 12:13:29 -0500

novicepuppetuser gravatar image

So I was reading that you can change the 30 minutes polling for reports by putting the runinterval in the puppet.config file, but when I did that, it doesn't seem to work. I also restarted the pe-puppet service after I change the puppet.config file as well and still doesn't work. I have it written as this in the file

runinterval = 8hr

I place it in the [main] part of the file. When it didn't work, I place the runinterval in all 3 parts, [main], [master], and [agent] and that still didn't work. Is there ... (more)

edit retag flag offensive close merge delete

Comments

Would you paste your entire puppet.conf file?

Ancillas gravatar imageAncillas ( 2013-08-13 13:42:05 -0500 )edit

If you remove it from the master and agent stanzas, and run "puppet agent --configprint runinterval", what gets returned? Also, what version are you on?

Celia gravatar imageCelia ( 2013-08-13 13:50:05 -0500 )edit

I'm running puppet 3.2.2. When I ran the comand "puppet agent --configprint runinterval" it printed out 1800. So that is in second which turn out to be ...(more)

novicepuppetuser gravatar imagenovicepuppetuser ( 2013-08-13 14:27:47 -0500 )edit

Have you restarted your puppet master since you made the change?

Ancillas gravatar imageAncillas ( 2013-08-13 17:27:52 -0500 )edit

Yes, I restarted the puppet master, with the following command "service pe-puppet restart" and it still not working

novicepuppetuser gravatar imagenovicepuppetuser ( 2013-08-14 11:04:21 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
6

answered 2013-08-15 10:02:53 -0500

GregLarkin gravatar image

The runinterval setting should be placed in the [agent] section of puppet.conf, and there's no need to restart the puppet master. If your agents are daemonized, the setting controls how often they connect to the master for updates.

The fact that you saw different runinterval values when running as root vs. non-root is not a bug. You will likely see different values emitted for the following command when running as root and non-root

puppet agent --configprint confdir

This means that different users load their configuration from different places. If your agent runs as root, make sure to change ... (more)

edit flag offensive delete link more

Comments

1

That did the trick. I had to go into each node and modify the puppet.config file and add in the runinterval in the [agent] section. Thank you for the help.

novicepuppetuser gravatar imagenovicepuppetuser ( 2013-08-15 14:52:10 -0500 )edit

Glad to hear it worked, and please accept my answer as correct when you have a moment - thank you!

GregLarkin gravatar imageGregLarkin ( 2013-08-15 15:07:22 -0500 )edit
0

answered 2015-03-07 06:53:13 -0500

Jason gravatar image

check with #puppet agent --configprint all|grep -i runinterval default is runinterval = 1800 30 minutes = 1800 seconds change it using below command #puppet config set runinterval 28800 28000 seconds = 8 hours

Note restart/reboot required & should be done as root

edit flag offensive delete link more
0

answered 2016-04-15 13:03:01 -0500

deric gravatar image

Run interval could be checked using single command:

puppet agent --configprint runinterval

Just add to /etc/puppet/puppet.conf:

[agent]
runinterval=1800

and restart agent.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-08-13 12:13:29 -0500

Seen: 14,849 times

Last updated: Apr 15 '16