Ask Your Question
1

The environment must be purely alphanumeric?

asked 2016-03-01 15:57:59 -0500

jnojr gravatar image

I'm working from https://docs.puppetlabs.com/puppet/3.... I'm using CentOS 6.7 I did 'yum install puppet-server', set the dna-alt names, and 'sudo puppet master --verbose --no-daemonize' It just spits out line after line of:

Error: The environment must be purely alphanumeric, not 'puppet-ca'

I looked through my environment for the string 'puppet' and found nothing. Googling hasn't helped. What "environment" is wrong, and why is it wrong out of the box? I've very literally done nothing but followed the tutorial.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-03-03 09:08:32 -0500

rnelson0 gravatar image

Try sudo puppet config print environmentpath and look in that directory for a subdirectory called puppet-ca. You can use underscores but not hyphens, IIRC.

If that directory is there, you'll need to determine why either A) the environmentpath is pointing to somewhere wonky (should be /etc/puppetlabs/code/environments or /etc/puppet/environments or similar, depending on version) or B) how a puppet-ca directory made it into that location.

edit flag offensive delete link more
0

answered 2016-03-02 01:14:41 -0500

rajeevsharma gravatar image

updated 2016-03-02 12:54:30 -0500

Did you name your environment "puppet-ca"? It won't work. Please see: https://docs.puppetlabs.com/puppet/4.3/reference/environments_creating.html#allowed-environment-names

Your suspicion is right. I would have asked so many questions like:

  • Did you create any additional environment?
  • If you created one does that have a name "puppet-ca"?
  • Did you accidentally change your default environment "production" to "puppet-ca"?
  • Did you mention any environment in puppet.conf which does not comply with naming conventions?

I might be wrong asking above questions but in simple words to your simple question "Yes, The environment must be purely alphanumeric".

edit flag offensive delete link more

Comments

What, exactly, do you mean by "naming my environment"? That sounds suspiciously like you're posting an answer just to post an answer.

jnojr gravatar imagejnojr ( 2016-03-02 09:50:36 -0500 )edit

We have found that a '-' is not a valid char for an environment, but a '_' is valid

DarylW gravatar imageDarylW ( 2016-03-03 22:36:48 -0500 )edit

I also don't see the string 'puppet-ca' on the page you linked.

DarylW gravatar imageDarylW ( 2016-03-04 22:48:23 -0500 )edit

I wanted to point out that I have since ran into this same issue, and it happens when you use a 4.x.x client with a 3.x.x master. See http://serverfault.com/questions/700181/error-400-on-server-the-environment-must-be-purely-alphanumeric-not-puppet-ca

DarylW gravatar imageDarylW ( 2016-03-24 19:29:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-01 15:57:59 -0500

Seen: 1,037 times

Last updated: Mar 03 '16