Ask Your Question
0

windows msi install ignores puppet master address [closed]

asked 2016-03-02 03:00:32 -0500

Jan Dvorak gravatar image

I've just installed puppet agent thru MSI on Win Server 2012 R2. (During the install it asks for puppet master address). I've checked that C:\ProgramData\PuppetLabs\puppet\etc\puppet.conf contains correct address and that it is resolvable from the host of the agent. However, when I run puppet agent --test --debug, it goes about creating local SSL certs and then tries to contact https://puppet:8140, which of course blows up. From what I can tell it ignores the master address configuration that has been entered during installation and now sits in puppet.conf. I've also verified that there are no environment variables related to puppet. Complete reinstall and server restart did not changed anything. I'd be glad for any suggestions on how to fix it.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Jan Dvorak
close date 2016-03-07 02:15:56.589878

Comments

Did you run the command as Administrator?

maynero gravatar imagemaynero ( 2016-03-02 16:04:30 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-05 14:00:55 -0500

rjc gravatar image

We can see neither your master, nor agent, configuration so it's a guessing game.

edit flag offensive delete link more
0

answered 2016-03-07 02:14:43 -0500

Jan Dvorak gravatar image

updated 2016-03-07 02:15:36 -0500

Did you run the command as Administrator?

Oh my... Yes, that was the problem. I did not and when I did it picked up the configuration as expected. Thanks maynero

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-03-02 02:57:45 -0500

Seen: 56 times

Last updated: Mar 07 '16