Ask Your Question

metadata.json and supported puppet version

asked 2016-03-03 04:18:19 -0600

luksi1 gravatar image

Am I missing something from the docs? Does metadata.json not contain a parameter regarding which puppet version your module is supported on? If it doesn't, where would you indicate that information?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-03-03 04:31:19 -0600

As far as I know, this works:

  "requirements": [
      "name": "pe",
      "version_requirement": ">= 3.0.0 < 2015.4.0"
      "name": "puppet",
      "version_requirement": ">= 3.0.0 < 5.0.0"

Based on the docs here you would be right that there's no mention of this in the official docs, although it's mentioned in this Puppet Labs blog post here.

edit flag offensive delete link more


@luksi Can you advise if this solved your problem and if so mark it as resolved, thanks.

Alex Harvey gravatar imageAlex Harvey ( 2016-03-08 22:11:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-03-03 04:18:19 -0600

Seen: 37 times

Last updated: Mar 03 '16