Ask Your Question
0

versioncmp in apache remoteip

asked 2016-03-04 06:35:23 -0500

dumbo gravatar image

if versioncmp($apacheversion, '2.4') < 0 { fail('modremoteip is only available in Apache 2.4') }

but in CentOS don't work with 2.4.6

httpd -v

Server version: Apache/2.4.6 (CentOS) Server built: Nov 19 2015 21:43:13

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-04 17:37:55 -0500

lavaman gravatar image

Not sure how you installed apache on that machine, but that logic is looking at the value of the apache_version variable in puppet, not something on the machine in question. If you aren't specifically setting an apache version, It's determined based on OS/version:

https://github.com/puppetlabs/puppetl...

Which appears to default to 2.2 unless you're running CentOS 7.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-03-04 06:35:23 -0500

Seen: 160 times

Last updated: Mar 04 '16