Ask Your Question
0

puppet node_vmware create fails with "The --template option must be a path" even though I can see the template VM listed in the "puppet node_vmware list" command output

asked 2013-08-14 07:06:38 -0600

lgoldstein gravatar image

updated 2013-08-14 12:24:51 -0600

GregLarkin gravatar image

puppet node_vmware list

Notice: Connecting ...
Notice: Connected to w.x.y.z as root (API version 4.1)
Notice: Finding all Virtual Machines ... (Started at 04:47:17 AM)
Notice: Control will be returned to you in 10 minutes at 04:57 AM if locating is unfinished.
Locating:          100% |ooooooo....ooooooo| Time: 00:00:00
Notice: Complete
/VMware vCenter Server Appliance
  powerstate: poweredOn
  name:       VMware vCenter Server Appliance
  hostname:   localhost
  instanceid: id1
  ipaddress:  1.2.3.4
  template:   false

/UI VM
  powerstate: poweredOn
  name:       UI VM
  hostname:   firstvm-external
  instanceid: id2
  ipaddress:  5.6.7.8
  template:   false

/Analytics VM
  powerstate ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-09-02 10:56:10 -0600

toddcc1 gravatar image

I had difficulty with this as well.

I found a fix here...

http://projects.puppetlabs.com/issues/21549

I edited the list virtual machines.rb per below and all is good now.

Just one line must be changed in this file /opt/puppet/lib/ruby/gems/1.9.1/gems/fog-1.5.0/lib/fog/vsphere/requests/compute/listvirtualmachines.rb

from this: if ( not folder.methods.include?(‘parent’) ) or ( folder == root )

to this: if ( not folder.respond_to?(:parent) ) or ( folder == root )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-08-14 07:06:38 -0600

Seen: 304 times

Last updated: Sep 02 '13