Ask Your Question
0

Puppet Enterprise Installtion Err

asked 2013-08-14 14:34:39 -0600

Sehar gravatar image

updated 2013-08-14 14:35:50 -0600

HI - I tried installing PE on RHEL for our POC and we are running into installtion issues. I tried several options and also followed :http://projects.puppetlabs.com/issues/21495: But i'm stuck with the same err.

Complete! Setting up puppet master...

Checking the agent certificate name detection...

Setting up puppet agent...

Setting up the database...

Configuring postgresql server...

PostgreSQL server configured.

!! ERROR: The PostgreSQL server failed to start; unable to proceed

Thanks Sehar Nalli

edit retag flag offensive close merge delete

Comments

1

Sehar, there should be an install log in the directory of the PE installer or the level above. The filename should be something like: install_log.lastrun.<fqdn> Please attach that ...(more)

bmurts gravatar imagebmurts ( 2013-08-14 15:15:47 -0600 )edit

Hi - I have the file but its too big to post here. i can send that to via email.

Sehar gravatar imageSehar ( 2013-08-15 09:33:00 -0600 )edit

Sehar - please post the contents to http://pastebin.com/ and then post the link back here so we can see the contents of the file.

GregLarkin gravatar imageGregLarkin ( 2013-08-15 13:49:34 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-31 14:30:46 -0600

updated 2016-03-31 14:31:11 -0600

In this instance my first port of call would be to have a look around in /var/log I've not used RHEL for a while but when I did I often run into issues like that which were normally a result of SELinux getting in the way.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-14 14:34:39 -0600

Seen: 271 times

Last updated: Mar 31 '16