Ask Your Question
0

having issues with a Windows client running the Puppet agent...

asked 2016-03-15 08:57:20 -0500

dcstone57 gravatar image

having issues with a Windows client running the Puppet agent...i get the following....

Running Puppet agent on demand ... Error: Could not request certificate: Error 400 on SERVER: The environment must be purely alphanumeric, not 'puppet-ca' Exiting; failed to retrieve certificate and waitforcert is disabled Press any key to continue . . .

.... i just set up an Ubuntu client, installed Puppet agent, did nothing else other than adding the puppet master IP to /etc/profile, and it ran fine....

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-15 16:10:56 -0500

souldonut gravatar image

Switch 'environment' over to production? Something about puppet not liking hyphens in environment names usually does the trick.

edit flag offensive delete link more
0

answered 2016-05-09 13:28:15 -0500

joshc gravatar image

That error message means you're using a puppet 4 agent on Windows connecting to a 3.x master, which is not supported. The agent is trying to make a REST request to /puppet-ca/v3/certificate, but older 3.x masters expect the HTTP request path to start with the environment name, e.g. /production/..., hence the error.

You'll want to either install a 3.8.x Windows agent, or upgrade your master to 4.x.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-03-15 08:57:20 -0500

Seen: 286 times

Last updated: May 09 '16