Ask Your Question
0

Error: Could not request certificate: Connection refused - connect(2) for "puppet" port 8140

asked 2016-03-16 06:34:40 -0500

Nirbhay gravatar image

I am new to puppet I am configuring connecting between puppet master "puppet" I have edited the host file on agent & client as well as I have edited the puppet.conf on agent node to resolve the master. I can ping in between both servers.

I checked on master for cert list but there were no requests.

But still I am getting this error.

How can fix this?

My configuration is :

Puppet master is :

Name: puppet, Agent: centos

Both are on VM

image description

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-03-17 11:23:02 -0500

rajeevsharma gravatar image

It's a very common issue if your master installation did not go successful or you haven't started puppet master. Can you please check if 8140 port is listening on master.

netstat -nap | grep 8140

If you don't see given port in the output you need to restart puppet master. If you're unable to restart or after restarting master if you don't get the port alive that denotes something got broken while installing puppet master. You can check the log for troubleshooting or in the long run go for fresh installation.

edit flag offensive delete link more

Comments

I have a similar issue, however `puppet resource service puppetserver ensure=running` will not change the value of ensure. You can see my problem in full detail here: http://stackoverflow.com/questions/38295737/puppet-server-cannot-be-changed-from-stopped-to-running

cohenaj194 gravatar imagecohenaj194 ( 2016-07-10 14:31:43 -0500 )edit
0

answered 2016-04-01 05:52:27 -0500

Nirbhay gravatar image

I figured out the problem. Issue was in new version of puppet we have to run enable the puppet server. Only starting the puppet server & services will not work we have to enable the server as well.
Following command is for starting the server :

puppet resource service puppetserver ensure=running

This command is to enable the server.

puppet resource service puppetserver enable=true
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-16 04:47:02 -0500

Seen: 10,349 times

Last updated: Apr 01 '16