Ask Your Question
0

Default manifest searched at /home/user/.puppetlabs/ instead of /etc/puppetlabs/

asked 2016-03-17 03:16:33 -0500

Hi there, I've recently started to play with Puppet Open Source but I'm experiencing some unexpected behaviors. Following the documentation, when we want to open a manifest we have to place it inside /etc/puppetlabs/code/environments/production/manifests/ on the Server side. Anyway, if I do so, the manifest is not applied on the Agent. Instead, I've found that if I place it inside /home/user/.puppetlabs/etc/code/environments/production/manifests/ it is then applied.

Any idea about why it is so? I'm running Puppet 4.3.2 on both Server and Agent and I've not changed any default setting.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-17 10:54:12 -0500

updated 2016-03-17 20:56:40 -0500

It's because you're running Puppet as a non-root user.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-17 03:16:33 -0500

Seen: 18 times

Last updated: Mar 17 '16