Ask Your Question
0

How can I correctly restart the puppet master?

asked 2016-03-17 08:39:07 -0500

PaulAtkinson1309 gravatar image

I think whilst trying to correct agent certificate on the master that I have caused another issue with the master not running correctly.

puppet agent -t Warning: Unable to fetch my node definition, but the agent run will continue: Warning: Connection refused - connect(2) Info: Retrieving pluginfacts Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'evalgenerate': Connection refused - connect(2) Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://puppet/pluginfacts: Connection refused - connect(2) Wrapped exception: Connection refused - connect(2) Info: Retrieving plugin Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'evalgenerate': Connection refused - connect(2) Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve file metadata for puppet://puppet/plugins: Connection refused - connect(2) Wrapped exception: Connection refused - connect(2) Error: Could not retrieve catalog from remote server: Connection refused - connect(2) Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run Error: Could not send report: Connection refused - connect(2)

Master service is running

[root@XXX /etc/puppet]# sudo puppet master --verbose --no-daemonize Notice: Starting Puppet master version 3.7.4 ^C Notice: Caught INT; calling stop

started puppet service

[root@XXX /etc/puppet]# sudo puppet resource service puppet ensure=running enable=true Notice: /Service[puppet]/ensure: ensure changed 'stopped' to 'running' service { 'puppet': ensure => 'running', enable => 'true', }

Nothing is running on port 8140 netstat -anpl | grep 8140 lsof -i :8140

What are the steps to correctly restart the master so that port 8140 is correctly active?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-17 13:25:44 -0500

lavaman gravatar image

You've manually started the master in the foreground. You're killing it when you hit CTRL-C. You should have a service for the master that is started the same way as any other service. Note this is not the puppet service. That's the agent service, not the master.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-17 08:39:07 -0500

Seen: 769 times

Last updated: Mar 17 '16