Ask Your Question
0

Service ':VersionedCodeService' not found

asked 2016-03-17 20:45:56 -0500

rnelson0 gravatar image

updated 2016-03-17 20:47:36 -0500

I recently saw this happen on a restart of puppetserver 2.3.0, but I have not seen this error show up in the googles before. Has anyone seen this?

[rnelson0@puppet ~]$ sudo systemctl start puppetserver
Job for puppetserver.service failed because the control process exited with error code. See "systemctl status puppetserver.service" and "journalctl -xe" for details.
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$ systemctl status puppetserver.service
● puppetserver.service - puppetserver Service
   Loaded: loaded (/usr/lib/systemd/system/puppetserver.service; enabled; vendor preset: disabled)
   Active: activating (start-post) since Fri 2016-03-18 01:41:26 UTC; 11s ago
  Process: 3091 ExecStartPre=/usr/bin/install --directory --owner=puppet --group=puppet --mode=775 /var/run/puppetlabs/puppetserver (code=exited, status=0/SUCCESS)
 Main PID: 3093 (java);         : 3094 (bash)
   CGroup: /system.slice/puppetserver.service
           ├─3093 /usr/bin/java -Xms2g -Xmx2g -XX:MaxPermSize=256m -XX:OnOutOfMemoryError=kill -9 %p -Djava.security.egd=/dev/urandom -cp /opt/puppetlabs/server/apps/puppetserver/puppet-server-release.jar clojure.main -m puppetlabs.tr...
           └─control
             ├─3094 /bin/bash /opt/puppetlabs/server/apps/puppetserver/ezbake-functions.sh wait_for_app
             └─3155 ps -p 3093

Mar 18 01:41:26 puppet systemd[1]: Starting puppetserver Service...
Mar 18 01:41:26 puppet java[3093]: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$
[rnelson0@puppet ~]$ journalctl -xe
Mar 18 01:41:25 puppet java[2987]: at clojure.lang.RestFn.invoke(RestFn.java:512)
Mar 18 01:41:25 puppet java[2987]: at clojure.lang.Var.invoke(Var.java:409)
Mar 18 01:41:25 puppet java[2987]: at clojure.lang.AFn.applyToHelper(AFn.java:178)
Mar 18 01:41:25 puppet java[2987]: at clojure.lang.Var.applyTo(Var.java:700)
Mar 18 01:41:25 puppet java[2987]: at clojure.main.main(main.java:37)
Mar 18 01:41:25 puppet systemd[1]: puppetserver.service: main process exited, code=exited, status=1/FAILURE
Mar 18 01:41:26 puppet systemd[1]: puppetserver.service: control process exited, code=exited status=1
Mar 18 01:41:26 puppet systemd[1]: Failed to start puppetserver Service.
-- Subject: Unit puppetserver.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit puppetserver.service has failed.
--
-- The result is failed.
Mar 18 01:41:26 puppet systemd[1]: Unit puppetserver.service entered failed state.
Mar 18 01:41:26 puppet systemd[1]: puppetserver.service failed.
Mar 18 01:41:26 puppet systemd[1]: puppetserver.service holdoff time over, scheduling restart.
Mar 18 01:41:26 puppet systemd[1]: Starting puppetserver Service...
-- Subject: Unit puppetserver.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit puppetserver.service has begun starting up.
Mar 18 01:41:26 puppet java[3093]: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Mar 18 01:41:46 puppet java[3093]: Exception in thread "main" java.lang.RuntimeException: Service ...
(more)
edit retag flag offensive close merge delete

Comments

This died around 0545 on 20160317. There were no changes to the puppet codebase at that time, it just went poof.

rnelson0 gravatar imagernelson0 ( 2016-03-17 21:01:57 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-03-17 21:35:50 -0500

rnelson0 gravatar image

Thanks to flaf on irc, I was pointed at the answer in the release notes for puppetserver 2.3.0. The puppet module I am using auto-upgraded me to it and the stanza was missing because my puppet module provides its own bootstrap.cfg:

puppetlabs.services.versioned-code-service.versioned-code-service/versioned-code-service

edit flag offensive delete link more

Comments

Please see also https://tickets.puppetlabs.com/browse/SERVER-1213 for more details on the issue. We'd like to get this fixed in an upcoming release so that upgrades will be easier going forward, so feel free to weigh in if you have suggestions on the best solution.

cprice404 gravatar imagecprice404 ( 2016-03-18 10:40:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-17 20:45:56 -0500

Seen: 681 times

Last updated: Mar 17 '16