Ask Your Question
0

Puppet Enterprise 2015.3.3 with code manager, environments don't show up in Puppet Enterprise Console

asked 2016-03-22 03:10:03 -0500

krdoor gravatar image

Hello community,

I did a new fresh install Puppet Enterprise 2015.3.3 and enabled code manager during install.

Now I have create 3 branches on the control repo: production, development and staging. Automatically deploying these environments by pushing code to the control repo works as expected.

Now I wanted to create the Development environment in Puppet Enterprise Console, but I can only select production or agent specified, so staging and development don't shown up.

Can someone tell me what I should do to get these environments shown in the PE Console?

Thanks in advance, Kristof

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-04-26 10:04:27 -0500

I just did a 2016 fresh install with code manager settings in the answer file. Where I expected to see the environments is in the Node Management-> Classification page but I didn't... On my git control repo I made a production/development/testing/sandbox branches and the production branch is the master renamed. Now the following worked but some might be unnecessary... I did (puppet-code --log-level debug --config-file /etc/puppetlabs/client-tools/puppet-code.conf --service-url "https://puppermaster.example.com:8170/code-manager" deploy production). Have a look at whats in /etc/puppetlabs/code-staging/ I started to see whats in my git repo being synced there, then did a (git remote -v && git status) and to see if it was pulling from the right place and did a (git pull); and it showed my branches. Run (git remote show cache && git remote show origin) to compare cache and origin. Then run 9git pull origin production && git fetch origin production), and then (puppet-code --log-level debug --config-file /etc/puppetlabs/client-tools/puppet-code.conf --service-url "https://puppetmaseter.example.com:8170/code-manager" deploy development) I then did the same for my branches/environments so deploy development ... deploy testing etc... then the folders/environments showed up in /etc/puppetlabs/code/environments.... I think I could have just run the last steps of puppet-code ...... deploy but just communicating the steps I tried

edit flag offensive delete link more
0

answered 2016-04-08 03:11:21 -0500

monty gravatar image

Hello Kristof,

My suggestion is to use the "refresh classes" button in the UI. You can reach this button by selecting a node group and then going to the classes tab. The "refresh classes" button is near the upper right hand corner.

That button will cause the environments to be loaded immediately. There is a background refresh process but it requires a full page refresh in your browser before you can see them which is why I recommend the refresh classes button.

Hope this help!

Regards,

Martin

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-22 03:10:03 -0500

Seen: 404 times

Last updated: Apr 08 '16