Ask Your Question
0

Invalid parameter headers on Class[Apache]

asked 2016-03-25 07:55:44 -0500

atakacs gravatar image

Hi.

I have an issue with one of the nodes in my puppet config. In the node's manifest I have this apache class

class { 'apache':
      default_vhost => true,
      mpm_module => false,
      trace_enable => 'Off', 
      keepalive => 'On', 
      keepalive_timeout => '10', 
      max_keepalive_requests => '100',
      headers => 'always append X-Frame-Options SAMEORIGIN',
}

When I run the puppet agent, this is what I get:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Invalid parameter headers on Class[Apache]

I don't know what is the problem here. I tried with different headers but I couldn't make it work.

Any suggestions?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-03-25 17:24:09 -0500

lavaman gravatar image

updated 2016-03-25 17:25:14 -0500

It's complaining that you're passing a parameter called headers. It's not looking at the value.

Assuming you are using puppetlabs-apache, headers is in fact not a valid parameter on the apache class. It's a valid parameter for the vhost defined type:

https://github.com/puppetlabs/puppetl...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-25 07:55:44 -0500

Seen: 180 times

Last updated: Mar 25 '16