libfacter was not built with JRuby support

asked 2016-04-01 17:08:36 -0600

janeliang gravatar image

Hi,

I failed to start the puppetserver and it told me there was a problem adding a JRubyPuppet instance. When I dug into the log file, I found out an error "libfacter was not built with JRuby support". Does anyone know if there's anything wrong with Facter or my environment? The system is RHEL5 and uses Ruby 1.8.7. Thank you!

edit retag flag offensive close merge delete

Comments

I think that error message means the 'facter.jar' file was not found. With puppet-agent 1.2+ packages, that file should be installed at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby, which should also be in the jruby-puppet.ruby-load-path in /etc/puppetlabs/puppetserver/conf.d/puppetserver.conf.

camlow325 gravatar imagecamlow325 ( 2016-04-02 19:42:54 -0600 )edit

puppet-agent 1.2+ is only supported with Puppet Server 2.x, but Puppet Server 2.x isn't being built for RHEL 5 AFAIK. For RHEL 5, I think you'd need to use puppetserver 1.x, puppet 3.x, and facter 2.x. Maybe you are trying to use the newer puppet-agent or just facter 3.x?

camlow325 gravatar imagecamlow325 ( 2016-04-02 19:56:45 -0600 )edit

yes I installed the newest package which ships facter 3.1.4. There is no 'factor.jar' at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby. I'll try to install the older versions now. Thanks!

janeliang gravatar imagejaneliang ( 2016-04-04 13:23:44 -0600 )edit

newbie here so excuse me for asking very basic/silly questions. I think if we install directly from puppetlabs repo, all we get are in latest version, right? So shall I download the corresponding rpms manually from the repo (yum.puppetlabs.com/el/5Server/products/x86_64/) and get them installed?

janeliang gravatar imagejaneliang ( 2016-04-04 14:40:34 -0600 )edit