Ask Your Question
0

Learning VM Power of Puppet - Task 3

asked 2016-04-03 16:28:36 -0500

nathannathannathan gravatar image

When running puppet agent --test I get this error:

[root@learning ~]# puppet agent --test
Info: Retrieving pluginfacts Info: Retrieving plugin Info: Loading facts Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Evaluation Error: Error while evaluating a Function Call, having $grwebserver => 'wsgionly' requires use of $grwebuser and $grwebgroup at /etc/puppetlabs/code/environments/production/modules/graphite/manifests/config.pp:65:9 on node learning.puppetlabs.vm Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run

I'm stuck. And I can't seem to find a solution to my problem anywhere.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-04 19:09:31 -0500

See: https://tickets.puppetlabs.com/browse...

The instructions provided in the guide don't work with the latest version of graphite. If you can start over, I would. Otherwise there are instructions in the linked ticket for uninstalling the newest version and installing the older one, although it didn't work for the person that originally opened it. I started over, installed the version referenced in the ticket, and made it through Task 3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-03 16:28:36 -0500

Seen: 73 times

Last updated: Apr 03 '16