Ask Your Question
0

Trying to connect puppetdb to postgres

asked 2016-04-05 11:31:26 -0500

Kornjack gravatar image

Getting the error PuppetDB requires PostgreSQL. The [database] section must contain an appropriate "//host:port/database" but postgresql is installed and the puppetdb.conf file is populated according to the instructions. The conf file resides at /etc/puppetlabs/puppetdb/puppetdb.conf.

[database]

classname = org.postgresql.Driver subprotocol = postgresql subname = //localhost:5432/puppetdb

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-06 16:04:05 -0500

Kornjack gravatar image

Since puppet was install by using packages and not with puppet commands the puppetdb.conf file resides in the conf.d directory. Fix that error now getting another error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-05 11:30:11 -0500

Seen: 124 times

Last updated: Apr 06 '16