Ask Your Question
0

Code Manager setup - missing 'puppet-code' binary

asked 2016-04-15 11:28:56 -0500

mike.r gravatar image

hi all, Im setting up Code Manager to manage my modules from a dev box via GitHub repo.

my dev box is same OS as my puppet master, centos7, and I have PE agent on it.

Im following the docs, and trying to install puppet-code binariy using this doc

https://docs.puppet.com/pe/latest/ins...peclient_tools.html#installing-pe-client-tools

I unzipped the PE tar package and installed the pe-client RPM,

[root@centos7node bin]# rpm -qa | grep pe-client
pe-client-tools-1.0.2-1.el7.x86_64

the docs say that this RPM should include this "puppet-code" binary, but I dont see it anywhere.

The package includes clients for the following services: Puppet orchestrator: Tools that provide the interface to the Application Orchestration service. These tools include puppet-job and puppet-app. Puppet Access: A client used to authenticate yourself to the PE RBAC token-based authentication service so that you can use other capabilities and APIs. Razor: The client for Razor, the provisioning application for deploying bare metal systems. Code Manager: A tool that provides the interface for the Code Manager and file sync services. This tool includes puppet-code.

Also in the console, I cant find the Puppet_Enterprise::Profile::Controller class, it doesnt exist.

Select the PE Controller group, and add the puppet_enterprise::profile::controller class. PE uses the puppet_enterprise::profile::controller class to manage client tools global configuration files.

Im running PE 2015.3.3

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-04-15 18:51:28 -0500

mike.r gravatar image

updated 2016-04-15 18:51:46 -0500

btw, the pe-client RPM does not contain the 'puppet-code' binary.

[root@centos7node /]# rpm -qlp /tmp/pe-client-tools-1.0.2-1.el7.x86_64.rpm | grep puppet-code

edit flag offensive delete link more
0

answered 2016-04-18 11:49:48 -0500

scotje gravatar image

The puppet-code CLI tool was a new feature of Puppet Enterprise 2016.1.

For PE 2015.3 you should make sure you are viewing the docs for that version rather than "latest": https://docs.puppet.com/pe/2015.3/ind...

edit flag offensive delete link more

Comments

gotcha, thanks, didnt notice my docs pages were set to 'latest'

mike.r gravatar imagemike.r ( 2016-04-19 11:26:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-15 11:28:56 -0500

Seen: 110 times

Last updated: Apr 15 '16