puppetboard error

asked 2016-04-15 17:23:17 -0600

nimish gravatar image

Hello All,

Trying to install puppetdb and puppetboard and running into an issue, I've searched the web as well as this forum to see if anyone has come across this and it seems like no one has. So I'm probably doing something wrong.

I've setup a puppet master and I'm in the middle of installing puppetdb and puppetboard on the same VM.

VM specs:
OS: CentOS Linux release 7.2.1511 (Core)
RAM: 16GB
CPU's: 8 vCPU's

I've used the following to install puppet server:

rpm -Uvh https://yum.puppetlabs.com/puppetlabs-release-pc1-el-7.noarch.rpm
yum install puppetserver

Puppet v4.4.1

puppet status
{
  "is_alive": true,
  "version": "4.4.1"
}

For puppetdb and puppetboard I'm installing them via puppet module install:

puppetlabs-puppetdb
nibalizer-puppetboard
puppetlabs-apache

When I try and do a test run I get the following error

puppet agent --noop --test
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Evaluation Error: Unknown variable: 'listen'. at /etc/puppetlabs/code/environments/production/modules/puppetboard/manifests/init.pp:225:6 on node puppet-master-01
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

Has anyone come across this error?

Here is my manifest for puppetdb/puppetboard

cat /etc/puppetlabs/code/environments/production/manifests/nodes/puppet-master-01.SubDomain.domain.com.pp

    # /etc/puppet/manifests/nodes/puppet-master-01.SubDomain.domain.com.pp

    node puppet-master-01 {
      # Configure puppetdb and its underlying database
      class { 'puppetdb':
          report_ttl        => '7d'
     }
      # Configure the Puppet master to use puppetdb
      class { 'puppetdb::master::config':
          manage_report_processor => true,
          enable_reports          => true
     }

      # Configure python
      class { 'python':
          virtualenv => true,
          pip        => true
     }

    # Configure Apache on this server
      class { 'apache': }
      class { 'apache::mod::wsgi':
          wsgi_socket_prefix => "/var/run/wsgi",
     }

    # Configure Puppetboard
      class { 'puppetboard': }

    # Access Puppetboard through pboard.example.com, port 8888
      class { 'puppetboard::apache::vhost':
          vhost_name => 'puppet-master-01.SubDomain.domain.com',
          port => '8888',
     }
}

I do have a site.pp which I can share as well if you think that's necessary.

Thanks in advance!

Nimish

edit retag flag offensive close merge delete

Comments

Looks like there is an issue with the module. Puppet is telling you to investigate `/etc/puppetlabs/code/environments/production/modules/puppetboard/manifests/init.pp` line 225

awippler gravatar imageawippler ( 2016-04-19 11:03:27 -0600 )edit