Ask Your Question
0

tie down facter version

asked 2016-04-18 05:18:19 -0600

hibbert gravatar image

Hi,

Currently we are tieing down the version of puppet on our nodes but not the facter version. I'm wandering if facter version should be tied down and if there is any correlation between the puppet version and facter?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-18 10:29:49 -0600

Yes, if you lock Puppet at a specific version you need to also lock Facter (and Hiera). I suggest browsing through old versions of the Puppet gems at Rubygems.org in order to know the corresponding Facter and Hiera version requirements.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-18 05:18:19 -0600

Seen: 19 times

Last updated: Apr 18 '16