Ask Your Question
0

puppet kick from master gets connection refused from agent

asked 2016-04-18 06:13:10 -0500

raghav gravatar image

updated 2016-04-18 09:40:23 -0500

I have installed puppet agent (windows) and master successfully. When i download the node from agent it works fine (puppet agent -t ) and the nodes are pulled successfully.

But when i trigger the same from the puppet master,

puppet kick --host agent01

i get connection error as below.

Error: Host agent01 failed: Connection refused - connect(2)

I did a wireshark in agent machine and i could see the connection made to agent at port 8139 and is responded with a red ACK message.

Since the connection has reached the agent, am assuming agent rejected the connection. Could some one please help me fix this problem.

Puppet.conf at agent

 [main]
 server=puppetmaster.localsky.biz
 autoflush=true environment=production
 pluginsync=true listen = true
 [agent]

auth.conf at agent:

path /
method find, search, save
auth yes
allow puppetmaster.localsky.biz

path /run
method find, search, save
auth yes
allow puppetmaster.localsky.biz

path C:/ProgramData/PuppetLabs/puppet/var/run
method find, search, save
auth yes
allow puppetmaster.localsky.biz

However, if i run puppet agent --no-daemonize --debug from the Powershell console, the build gets pushed successsfully.

So the failure happens only if run the agent from Puppet Agent as windows service.

edit retag flag offensive close merge delete

Comments

1

I believe puppet kick was removed in favor of mcollective.

awippler gravatar imageawippler ( 2016-04-19 11:05:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-04 10:23:49 -0500

Nirbhay gravatar image

puppetserver listens on port 8140 on version 4+

you can always check if a port is listening by

$ netstat -nap | grep 8140

try running following command from master

Following command is for starting the server :

$ puppet resource service puppetserver ensure=running

This command is to enable the server.

$ puppet resource service puppetserver enable=true

Let me know if it worked or not.

edit flag offensive delete link more

Comments

puppet kick was deprecated in 3.x, and removed in 4.x

DarylW gravatar imageDarylW ( 2016-05-04 22:18:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-18 06:13:10 -0500

Seen: 189 times

Last updated: May 04 '16