Ask Your Question
0

Newbie with Persistent Error: "Error 400 on SERVER: Could not find default node or by name..."

asked 2016-04-20 15:56:35 -0600

nwunye gravatar image

I have tried to make my question as detailed as possible, to aid my responders.

I am running RHEL 6.5 on all servers I use. I am trying to set up a 2-node cluster. I installed pkgs "ricci" and all its related pkgs

Cluster Server: cluster.localdomain (192.168.1.9)

All ports are open and the puppet service is running on all servers.

Content of puppet.conf on Master:

[main]
altnames = puppet,cluster.localdomain
Content of puppet.conf on Nodes:

[main]

(comment) The Puppet Master

[agent]

Content of /etc/puppet/manifests/site.pp file:

node 'node02.localdomain' {

Whenever I run "puppet agent -t" I get the following error:

Info: Retrieving pluginfacts

I would truly appreciate any help at all. I am brand new to Puppet. Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-22 04:39:17 -0600

It sounds like you're trying to build a 2-node Red Hat Cluster for the Puppet Master - is that correct? If so, I suspect you're going to have an interesting journey, because the recommended way to scale out multiple Puppet Masters is in the so-called "Master of Masters" configuration.

The documentation for doing this using open source Puppet is here, although it doesn't appear to have been updated since Puppet 3.2. If you're using Puppet Enterprise, follow the links in that document to the correct documents for PE.

If you have some hard requirement to use Red Hat Cluster, I'd consider raising this issue in the Puppet mailing list. You might get more help there.

Note that "Info: Retrieving pluginfacts" isn't an error message, and in fact is part of normal operation, but the fact that it's hanging there suggests some kind of network issue (maybe related to the clustering?) is preventing the agents from receiving the plugin-synced facts.

edit flag offensive delete link more

Comments

Puppet Enterprise documentation refers to this as LEI, with the latest documentation for setting it up at https://docs.puppet.com/pe/2016.1/install_multimaster.html.

MichaelSmith gravatar imageMichaelSmith ( 2016-04-25 11:40:12 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-20 15:56:35 -0600

Seen: 232 times

Last updated: Apr 22 '16