Ask Your Question
0

Could not request certificate: getaddrinfo: Name of service not known

asked 2016-05-06 04:20:12 -0600

Semerson gravatar image

Hi guys, I've recently installed PE 2016 on an EC2 Instance. After the installation is complete I followed the steps on puppet docs: - Click Add class. (Adding the Ubuntu 14.04 OS under the PE master group) - Click Commit 1 change. Note: The class you selected now appears in the list of classes for the PE Master group, but it has not yet been configured on your nodes. For that to happen, you need to kick off a Puppet run. - From the command line on the Puppet master, run puppet agent -t.

The last line, run puppet agent -t doesn't work for me, I've been stuck on trying to figure out for a long time :/ I get the error;

Error: Could not request certificate: getaddrinfo: Name or service not known Exiting; failed to retrieve certificate and waitforcert is disabled

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-06 20:52:00 -0600

DarylW gravatar image

That means that you aren't resolving your puppet master. If you haven't specified a 'server' value in your puppet config

If you haven't set it, you'll see something like the following..

ubuntu:~$ puppet config print server puppet

By default, puppet looks for a server at 'puppet', but you can either speify your server while running puppet (--server your.server.address), or you can set the value in your puppet config. ( puppet config set server your.server.address --section agent)

You also could add your puppet master's address to your /etc/hosts file as 'puppet'

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-05-06 04:20:12 -0600

Seen: 8,971 times

Last updated: May 06 '16