Ask Your Question
0

Seeing a lot of this err: Failed to apply catalog: You cannot specify more than one of content, source, target at /cloud/puppet/production/modules/concat/manifests/init.pp:164

asked 2016-05-09 23:23:24 -0500

Anandk gravatar image

updated 2016-05-09 23:23:56 -0500

Seems to happen on some of our nodes, attached that code chunk:

  "${fragdir}/${concat_name}":
        ensure   => present;

     $name:
        source   => "${fragdir}/${concat_name}",
        owner    => $owner,
        group    => $group,
        checksum => md5,
        mode     => $mode,
        ensure   => present,
        alias    => "concat_${name}";
}

Anyone can shed some light? BTW I didn't write this. We are running OSS puppet 2.7.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-10 08:19:21 -0500

try removing the extra ensure => present - duplicate..

edit flag offensive delete link more

Comments

excellent, let me get the CR's out to make this changes. Will get back

Anandk gravatar imageAnandk ( 2016-06-08 00:44:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-09 23:23:24 -0500

Seen: 103 times

Last updated: May 10 '16