Ask Your Question
0

Warning: Unable to fetch my node definition, but the agent run will continue: Warning: getaddrinfo: No such host is known.

asked 2016-05-10 08:42:14 -0500

fgbulsoni gravatar image

Hey guys,

I'm just beginning to try and figure out puppet and I've tried running the installer on windows to have a client and use it as a learning step standalone install. I've created and updated my puppet.conf file, and generated a cert for my machine, but when I try to run the puppet agent, I get the following error:

Warning: Unable to fetch my node definition, but the agent run will continue: Warning: getaddrinfo: No such host is known. Info: Retrieving pluginfacts Error: /File[C:/ProgramData/PuppetLabs/puppet/cache/facts.d]: Failed to generate additional resources using 'eval_generate': getaddrinfo: No such host is known.

Error: /File[C:/ProgramData/PuppetLabs/puppet/cache/facts.d]: Could not evaluate : Could not retrieve file metadata for puppet:///pluginfacts: getaddrinfo: No su ch host is known. Info: Retrieving plugin Error: /File[C:/ProgramData/PuppetLabs/puppet/cache/lib]: Failed to generate add itional resources using 'eval_generate': getaddrinfo: No such host is known. Error: /File[C:/ProgramData/PuppetLabs/puppet/cache/lib]: Could not evaluate: Co uld not retrieve file metadata for puppet:///plugins: getaddrinfo: No such host is known. Error: Could not retrieve catalog from remote server: getaddrinfo: No such host is known. Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run Error: Could not send report: getaddrinfo: No such host is known.

Is there a critical step I might be missing or can be referred to?

Thank you.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2016-05-11 16:03:29 -0500

awippler gravatar image

Your agent can't find the master. Ensure the master/server service is running and the agent can reach the fqdn of the master. It could also be that your agent's puppet.conf file does not have the server setting - it defaults to puppet.

You can override the setting by opening an elevated command prompt with the puppet shell and running puppet agent -t --server=puppet.domain.local

edit flag offensive delete link more

Comments

This is my exact recommendation, good answer

DarylW gravatar imageDarylW ( 2016-05-11 21:55:34 -0500 )edit
0

answered 2016-05-12 07:47:47 -0500

fgbulsoni gravatar image

Thank you very much to all replies, I finally now understand that I should NOT run puppet agent unless I do have a master, and since I'm going for a standalone puppet this is not the case. Thank you all.

edit flag offensive delete link more
-1

answered 2016-05-10 14:00:02 -0500

hKothuri gravatar image

Try cleaning and generating the certificate.

  1. Delete the SSL directory in windows in C:\ProgramData\PuppetLabs\puppet\etc
  2. Do "puppet cert clean node.example.com" on puppet master
  3. Run "puppet agent -t" from your node machine ( You will see like "generating new ssl cert n all)
  4. Sign the certificate from Foreman.
  5. Repeat step 3.
edit flag offensive delete link more

Comments

Thank you for the reply. To better specify the install, I'm running on windows 7 and expected this to be a standalone install. I tried following your steps and also running a puppet cert generate <fqdn of="" my="" node="">, however I end up with the same error messages as posted before.

fgbulsoni gravatar imagefgbulsoni ( 2016-05-11 16:15:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-10 08:42:14 -0500

Seen: 3,157 times

Last updated: May 12 '16