Ask Your Question
0

Unable to install puppetserver on ubuntu 16.04

asked 2016-05-13 08:38:25 -0500

newcomer gravatar image

Dear All,

I having difficulty installing puppetserver on my ubuntu. I following exact instructions and having no charm.

jim@jim-beam-VirtualBox:~/Desktop$ sudo dpkg -i puppetlabs-release-pc1-xenial.deb 
[sudo] password for jim: 
(Reading database ... 282230 files and directories currently installed.)
Preparing to unpack puppetlabs-release-pc1-xenial.deb ...
Unpacking puppetlabs-release-pc1 (1.0.0-2xenial) over (1.0.0-2xenial) ...
Setting up puppetlabs-release-pc1 (1.0.0-2xenial) ...
jim@jim-beam-VirtualBox:~/Desktop$ sudo apt-get update
Hit:1 http://au.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://au.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                                                      
Hit:3 http://au.archive.ubuntu.com/ubuntu xenial-backports InRelease                                                                                                    
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                            
Get:5 http://security.ubuntu.com/ubuntu xenial-security InRelease [93.3 kB]                      
Ign:6 http://apt.puppetlabs.com xenial InRelease                               
Hit:7 http://apt.puppetlabs.com xenial Release                                 
Hit:8 http://dl.google.com/linux/chrome/deb stable Release                           
Fetched 93.3 kB in 1s (67.7 kB/s)                                                    
Reading package lists... Done
W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)
W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 3B068FB4789ABE4AEFA3BB491397BC53640DB551 uses weak digest algorithm (SHA1)
jim@jim-beam-VirtualBox:~/Desktop$ sudo apt-get install puppetserver
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package puppetserver
jim@jim-beam-VirtualBox:~/Desktop$

How to install it ?

edit retag flag offensive close merge delete

Comments

When I installed it with puppetmaster command I have no idea why it came with older version 3.7.2 ??? I want the newer one 4.4 I believe puppet did a big change from 3.X to 4.X jim@puppet:~$ ps -aef|grep puppet|grep -v grep avahi 509 1 0 May14 ? 00:00:00 avahi-daemon: running [pupp

newcomer gravatar imagenewcomer ( 2016-05-14 09:52:51 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2016-05-13 10:50:43 -0500

csharpsteen gravatar image

At this time, 5/13/2016, the Puppet Engineering teams are still working on packaging Puppet Server for Ubuntu 16.04. Once this work is completed, the release will likely be announced on mailing lists such as puppet-announce:

https://groups.google.com/forum/#!for...

edit flag offensive delete link more
0

answered 2016-05-13 21:53:55 -0500

newcomer gravatar image

ACtually puppetmaster does help. What is really annoying is then their documentation. It should say puppetmaster instead of puppetserver

edit flag offensive delete link more
0

answered 2016-05-13 09:37:45 -0500

The package "puppetserver" has been renamed to "puppetmaster". So try, instead:

$ sudo apt-get install puppetmaster

Last I looked, the "xenial.deb" package does not yet contain PuppetDB

edit flag offensive delete link more

Comments

Sorry mate but puppetmaster is different from puppetserver. I installed 15.04 Ubuntu and can found puppetserver. It is coming with correct configuration files as well.

newcomer gravatar imagenewcomer ( 2016-05-14 20:23:53 -0500 )edit

In Ubuntu 15.04, which is not LTS, it is still puppetserver in puppetlabs-release-pc1-vivid.deb. We are talking about using Ubuntu 16.04 LTS with puppetlabs-release-pc1-xenial.deb, where the server has been renamed to puppetmaster. Also the bin directory has been changed /usr/bin.

stpierre gravatar imagestpierre ( 2016-05-16 09:14:04 -0500 )edit

There is additional documentation on Puppet from Ubuntu at https://help.ubuntu.com/lts/serverguide/puppet.html

stpierre gravatar imagestpierre ( 2016-05-16 09:20:46 -0500 )edit
0

answered 2016-05-15 09:18:34 -0500

camlow325 gravatar image

As mentioned in another answer, there are currently no released Puppet Server packages for Ubuntu 16.04, although there is an upcoming release planned to support this. If you would be interested in trying out a pre-release version, though, you could use the Xenial packages at http://nightlies.puppetlabs.com/puppe....

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-13 08:38:25 -0500

Seen: 1,790 times

Last updated: May 15 '16