No configuration file present for puppet on Ubuntu 15.10 ?

asked 2016-05-14 09:39:17 -0600

newcomer gravatar image

Hello All,

Somehow I managed to install puppetmaster on my VM(Ubuntu 15.10) and to my surprise my puppermaster file is empty !

Is there any step I missed?? On High level I downloaded puppet repository file and installed with dpkg command and then installed puppetmaster.

My puppet configuration file is like this.

jim@puppet:~$ sudo cat /etc/default/puppetqd 
# Defaults for puppetqd - sourced by /etc/init.d/puppetqd

# Should puppetqd (the storeconfigs queuing broker) be started? 
#  This can take some load off of the puppetmaster by queuing the
#  storeconfig updates to the database with puppetqd. You need
#  to have the 'stompserver' package installed and running, and
#  the following configured in your puppet.conf:
#
#  [main]
#  queue_type = stomp
#  queue_source = stomp://localhost:61613
#  dbadapter = (sqlite3|mysql|postgresql)
#  dbserver=localhost
#  dbname=puppet
#  dbuser=puppet
#  dbpassword=xxxx
#  dblocation = /var/lib/puppet/storeconfigs.sqlite <-- only if using sqlite
#
#  [master]
#  async_storeconfigs = true
#
#  See: http://reductivelabs.com/trac/puppet/wiki/UsingStoredConfiguration
#
#  Once you have the proper puppet.conf, and stompserver, you can enable
#  the following:
PUPPETQD=no
PUPPETQD_OPTS=""
jim@puppet:~$

I want to minimize the memory configuration, I believe default is 2G which I want to bring it down to 512MB.

Any help would be highly appreciated.

Kind Regards, Jim

edit retag flag offensive close merge delete