Ask Your Question
0

Unable to create a signing request to server(agent to server communication issue)

asked 2016-05-16 00:20:40 -0500

newcomer gravatar image

Hi All,

It seems that I am having some issue with creating a signing request from agent to server.

client can ping sever and vice-versa. Even they can do ssh to each other.

I am unable to understand why client is not able to create a signing request for server?

At server:

  jim@puppet:~$ ps -aef|grep 8140|grep -v grep
jim@puppet:~$ ps -aef|grep puppet|grep -v grep
avahi      532     1  0 10:51 ?        00:00:00 avahi-daemon: running [puppet.local]
root      1322     1  0 10:52 ?        00:00:09 /opt/puppetlabs/puppet/bin/ruby /opt/puppetlabs/puppet/bin/mcollectived --pid=/var/run/puppetlabs/mcollectived.pid --config=/etc/puppetlabs/mcollective/server.cfg --daemonize
root      1612     1  0 10:53 ?        00:00:00 /opt/puppetlabs/puppet/bin/ruby /opt/puppetlabs/puppet/bin/puppet agent
jim@puppet:~$

At Client:

[root@agent1 ~]# puppet agent --test
Info: Creating a new SSL key for agent1.netgear
Error: Could not request certificate: Connection refused - connect(2) for "puppet" port 8140
Exiting; failed to retrieve certificate and waitforcert is disabled

Again at client side:

[root@agent1 ~]# telnet puppet 22
Trying 192.168.1.7...
Connected to puppet.
Escape character is '^]'.
SSH-2.0-OpenSSH_6.7p1 Ubuntu-5ubuntu1.4
bye
Protocol mismatch.
Connection closed by foreign host.
[root@agent1 ~]# ssh jim@puppet
jim@puppet's password: 
Welcome to Ubuntu 15.04 (GNU/Linux 3.19.0-59-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

New release '15.10' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Mon May 16 15:18:15 2016 from agent1
jim@puppet:~$

What might be the reason for this and how to have it resolved?

Any help would be greatly appreciated !

Jim

edit retag flag offensive close merge delete

Comments

Looks like your server system is not running the server processes. Have you installed and started the puppet server?

Richard Berwald gravatar imageRichard Berwald ( 2016-05-16 02:08:21 -0500 )edit

I think you are right. I did install and I thought it would automatically. Apparently that is not the case. When I try to start it exits ! I am not sure why or where to look for more information. jim@puppet:~$ service puppetserver status ● puppetserver.service - LSB: puppetserver Loaded: loaded

newcomer gravatar imagenewcomer ( 2016-05-16 04:23:46 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-05-16 04:25:19 -0500

newcomer gravatar image

I think you are right. I did install and I thought it would automatically. Apparently that is not the case. When I try to start it exits ! I am not sure why or where to look for more information.

 jim@puppet:~$ service puppetserver status
● puppetserver.service - LSB: puppetserver
   Loaded: loaded (/etc/init.d/puppetserver)
   Active: active (exited) since Mon 2016-05-16 19:20:40 AEST; 2min 51s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3426 ExecStop=/etc/init.d/puppetserver stop (code=exited, status=0/SUCCESS)
  Process: 3432 ExecStart=/etc/init.d/puppetserver start (code=exited, status=0/SUCCESS)

May 16 19:20:02 puppet systemd[1]: Starting LSB: puppetserver...
May 16 19:20:40 puppet systemd[1]: Started LSB: puppetserver.
May 16 19:21:22 puppet systemd[1]: Started LSB: puppetserver.
jim@puppet:~$
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-16 00:20:40 -0500

Seen: 133 times

Last updated: May 16 '16