mcollective port change and ping issue

asked 2016-05-18 03:25:15 -0600

demethyl gravatar image

updated 2016-05-18 03:28:42 -0600

Hello,

i am creating a second post (different from https://ask.puppet.com/question/26184...) because there is some data changing between the 2 use cases.

The case is simple

1/ install a PE
2/ dont create a new env : everything is done en production env
3/ add a second puppet agent (the one with the master + a new one)

Those 2 agents are listed in the PE MCollective Classification do a mco ping : all is OK because ActiveMQ listens on default port 61613.

Change the port to 61617 or 2016, or whatever you want :

  • on PE MCollective classification : on class puppetenterprise::profile::mcollective::agent, set stompport=YOURPORTVALUE

  • on PE ActiveMQ Broker classification: on class puppetenterprise::profile::amq::broker set stompport=YOURPORTVALUE

Start puppet runs on the both nodes to update the Broker port, and the mcollective for both agents.

In /var/log/puppetlabs/mcollective.log :
[2016-05-18T10:15:56.828924 #15660] INFO -- : activemq.rb:119:in `on_connected' Connected to stomp+ssl://mcollective@myhost.mydomain:YOURPORTVALUE

=> the connection of the agents to the brokers are OK.

However, the mco ping doesn't responde.

In my use case, the default agent provided with PE is a RedHat agent. The added agent is a Windows 2008 R2 agent.

=> the same non responsive situations appears with windows and linux agents.

Am i doing something wrong while trying to change the port on which the PE ActiveMQ Brokers listens to the connected agents?

Thanks a lot for your answers, Guillaume

edit retag flag offensive close merge delete

Comments

Do you have some output on the mco ping? It's possible the configuration you're trying to use to trigger the ping uses the wrong port; that would be in the mcollective client configuration.

MichaelSmith gravatar imageMichaelSmith ( 2016-06-20 15:25:03 -0600 )edit

Hello again Michael, Do you mean i should configure client.cfg on the agent nodes ?

demethyl gravatar imagedemethyl ( 2016-06-24 04:50:20 -0600 )edit

i just found : https://docs.puppet.com/pe/latest/orchestration_config.html#changing-the-port-used-by-mcollectiveactivemq then i restarted the activemq service, nothing changed i also did a puppet agent -t on a node, and the client.cfg nor server.cfg were updated

demethyl gravatar imagedemethyl ( 2016-06-24 08:17:19 -0600 )edit

Hello, i digged further and this time i have a different behaviour : i want to use 32226 port instead of 61613 on stomp + ssl. It is configured on my windows desktop (client.cdf and server.cfg) and in activemq.xml. when i do a mco ping from the client i have this stack in mcollective.log :

demethyl gravatar imagedemethyl ( 2016-06-27 03:28:30 -0600 )edit

: runner.rb:207:in `rescue in block in receiver_thread' /opt/puppetlabs/puppet/lib/ruby/2.1.0/psych.rb:370:in `parse_stream' /opt/puppetlabs/puppet/lib/ruby/2.1.0/psych.rb:318:in `parse' /opt/puppetlabs/puppet/lib/ruby/2.1.0/psych.rb:245:in `load' /opt/puppetlabs/puppet/lib

demethyl gravatar imagedemethyl ( 2016-06-27 03:29:18 -0600 )edit