Puppet installation bug and how to resolve it?

asked 2016-05-18 10:08:20 -0600

newcomer gravatar image

Hey Guys,

Not sure if you have noticed but while installed puppet on Ubuntu 15.04 I experience three certificate related errors.

root@jim-Ubuntu1504:/home/jim/Downloads# apt-get install puppetserver
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  ca-certificates-java java-common openjdk-8-jre-headless puppet-agent
Suggested packages:
  default-jre equivs openjdk-8-jre-jamvm fonts-dejavu-extra fonts-ipafont-gothic fonts-ipafont-mincho ttf-wqy-microhei ttf-wqy-zenhei fonts-indic
The following NEW packages will be installed:
  ca-certificates-java java-common openjdk-8-jre-headless puppet-agent puppetserver
0 to upgrade, 5 to newly install, 0 to remove and 3 not to upgrade.
Need to get 110 MB of archives.
After this operation, 389 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://au.archive.ubuntu.com/ubuntu/ vivid/main ca-certificates-java all 20140324 [12.3 kB]
Get:2 http://apt.puppetlabs.com/ vivid/PC1 puppet-agent amd64 1.4.1-1vivid [13.7 MB]
Get:3 http://au.archive.ubuntu.com/ubuntu/ vivid/main java-common all 0.52 [131 kB]
Get:4 http://au.archive.ubuntu.com/ubuntu/ vivid/universe openjdk-8-jre-headless amd64 8u45-b14-1 [63.1 MB]
Get:5 http://apt.puppetlabs.com/ vivid/PC1 puppetserver all 2.3.1-1puppetlabs1 [32.8 MB]                                                                                 
Fetched 110 MB in 2min 6s (866 kB/s)                                                                                                                                     
Selecting previously unselected package ca-certificates-java.
(Reading database ... 172239 files and directories currently installed.)
Preparing to unpack .../ca-certificates-java_20140324_all.deb ...
Unpacking ca-certificates-java (20140324) ...
Selecting previously unselected package java-common.
Preparing to unpack .../java-common_0.52_all.deb ...
Unpacking java-common (0.52) ...
Selecting previously unselected package openjdk-8-jre-headless:amd64.
Preparing to unpack .../openjdk-8-jre-headless_8u45-b14-1_amd64.deb ...
Unpacking openjdk-8-jre-headless:amd64 (8u45-b14-1) ...
Selecting previously unselected package puppet-agent.
Preparing to unpack .../puppet-agent_1.4.1-1vivid_amd64.deb ...
Unpacking puppet-agent (1.4.1-1vivid) ...
Selecting previously unselected package puppetserver.
Preparing to unpack .../puppetserver_2.3.1-1puppetlabs1_all.deb ...
Unpacking puppetserver (2.3.1-1puppetlabs1) ...
Processing triggers for ca-certificates (20141019ubuntu0.15.04.1) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....done.
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for doc-base (0.10.6) ...
Processing 2 added doc-base files...
Processing triggers for systemd (219-7ubuntu6) ...
Processing triggers for ureadahead (0.100.0-19) ...
Setting up java-common (0.52) ...
Setting up puppet-agent (1.4.1-1vivid) ...
Created symlink from /etc/systemd/system/multi-user.target.wants/puppet.service to /lib/systemd/system/puppet.service.
Created symlink from /etc/systemd/system/multi-user.target.wants/mcollective.service to /lib/systemd/system/mcollective.service.
Created symlink from /etc/systemd/system/multi-user.target.wants/pxp-agent.service to /lib/systemd/system/pxp-agent.service.
Removed symlink /etc/systemd/system/multi-user.target.wants/pxp-agent.service.
Setting up ca-certificates-java (20140324) ...
**/var/lib/dpkg/info/ca-certificates-java.postinst: line 53: java: command not found
/var/lib/dpkg/info/ca-certificates-java.postinst: line 66: java: command not found**
done.
Processing triggers for ca-certificates (20141019ubuntu0.15.04.1) ...
Updating certificates in /etc/ssl/certs... 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d....
**/etc/ca-certificates/update.d/jks-keystore: 82: /etc/ca-certificates/update.d/jks-keystore: java: not found
E: /etc/ca-certificates/update.d/jks-keystore exited with code ...
(more)
edit retag flag offensive close merge delete

Comments

Those look like java errors and not related to puppet.

awippler gravatar imageawippler ( 2016-05-18 18:58:21 -0600 )edit

Understand that but What are the implications. How can the puppetlabs documentation be updated so as the users won't see this error. It should be a clean install.

newcomer gravatar imagenewcomer ( 2016-05-19 08:03:33 -0600 )edit

Why should puppet docs include issues for every install on every available platform? It is assumed that the reader of the documentation knows their distribution and can fix/ignore distribution specific issues. From your post, puppet installed correctly and had no issues installing.

awippler gravatar imageawippler ( 2016-05-19 10:55:28 -0600 )edit