Puppet master and agent on same RHEL server issue

asked 2016-05-20 07:04:01 -0500

Linkback gravatar image

updated 2016-05-21 01:20:33 -0500

Hi, I'm new on Puppet and just start learning it. and now I had installed both puppet master and agent on my RHEL linux server.

Here is the infor about my server:

  • RHEL ver. 7.2
  • Puppet master ver. 3.8.7
  • Puppet agent ver. 3.8.7

And I had updated the puppet.conf to included the PUPPET_SERVER=puppet.server.com under [main] and also add server=puppet.server.com under [agent].

Then restarted the puppetmaster service.

Then I created simple manifest file. and then try to test by run puppet agent --test but I'm getting below error message:

Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Connection refused - connect(2)
Info: Retrieving pluginfacts
Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': Connection refused - connect(2)
Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://puppet.server.com/pluginfacts: Connection refused - connect(2)
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate': Connection refused - connect(2)
Error: /File[/var/lib/puppet/lib]: Could not evaluate: Could not retrieve file metadata for puppet://puppet.server.com/plugins: Connection refused - connect(2)
Info: Loading facts
Error: Could not retrieve catalog from remote server: Connection refused - connect(2)
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
Error: Could not send report: Connection refused - connect(2)

Could anyone help me on this error?

Thanks L

edit retag flag offensive close merge delete

Comments

1

It doesn't seem like the puppet master is running. Have you verified that it is?

rilindo gravatar imagerilindo ( 2016-05-20 14:48:52 -0500 )edit

Thanks Rilindo, you are right, my puppet master isn't started. after start, it works fine then.

Linkback gravatar imageLinkback ( 2016-05-23 05:50:19 -0500 )edit