ntpd service not working on all agents

asked 2016-05-24 10:07:46 -0500

newcomer gravatar image

Hello Puppeters ! Good day.

I have an issue with my puppetserver agent and agent on another vm. The puppetserver agent gives error and the one another vm says that the service is not enabled and is not running. Code on puppetserver is as follows:

root@jim-Ubuntu1504:/etc/puppetlabs/code/environments/production/manifests# puppet agent -t
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for jim-ubuntu1504.netgear
Info: Applying configuration version '1464102234'
Notice: /Stage[main]/Motd/File[/etc/motd]/content: 
--- /etc/motd   2016-05-25 00:39:55.399355533 +1000
+++ /tmp/puppet-file20160525-8236-m49ztu        2016-05-25 01:03:54.825520642 +1000
@@ -1,3 +1,3 @@

-The current Debian time is 2016-05-25 00:39:54 +1000
+The current Debian time is 2016-05-25 01:03:54 +1000


Info: Computing checksum on file /etc/motd
Info: /Stage[main]/Motd/File[/etc/motd]: Filebucketed /etc/motd to puppet with sum 0d413d928784b6a6df5efe2094850c66
Notice: /Stage[main]/Motd/File[/etc/motd]/content: content changed '{md5}0d413d928784b6a6df5efe2094850c66' to '{md5}5dd1963e492aa78489f347eb71816ece'
Notice: I am installing the stuff the way you have told me Sir
Notice: /Stage[main]/Mystuff/Notify[I am installing the stuff the way you have told me Sir]/message: defined 'message' as 'I am installing the stuff the way you have told me Sir'
Notice: Applied catalog in 0.17 seconds
root@jim-Ubuntu1504:/etc/puppetlabs/code/environments/production/manifests# puppet resource service ntpd
Error: Could not run: #<IO:0x00000001f0e9d8>
root@jim-Ubuntu1504:/etc/puppetlabs/code/environments/production/manifests#

On another agent1 and 2 it works fine

[root@agent1 ~]# puppet resource service ntpd
service { 'ntpd':
  ensure => 'running',
  enable => 'true',
}
[root@agent1 ~]# 

[root@agent2 ~]# puppet resource service ntpd
service { 'ntpd':
  ensure => 'running',
  enable => 'true',
}
[root@agent2 ~]#

And this is the problematic node, no idea why it is not getting instructions from master

root@agent3:~# puppet resource service ntpd
service { 'ntpd':
  ensure => 'stopped',
  enable => 'false',
}
root@agent3:~#

Why ntpd is not running on agent3??

edit retag flag offensive close merge delete

Comments

Are all three agents running the same OS version? What does your code look like?

UBPClaw gravatar imageUBPClaw ( 2016-05-25 17:15:15 -0500 )edit

Actually you make a good point ! The third agent has Debian 8(Jessie) however the tutorial doesn't mention that you have to have a different code for different family os.

newcomer gravatar imagenewcomer ( 2016-05-26 08:38:20 -0500 )edit

root@jim-Ubuntu1504:/etc/puppetlabs/code/environments/production/manifests# cat site.pp node default { class {'motd':} class {'mystuff':} class { 'ntp': servers => ['nist-time-server.eoni.com','nist1-lv.ustiming.org','ntp-nist.ldsbc.edu'] } } Code as above on puppetserver.

newcomer gravatar imagenewcomer ( 2016-05-26 08:38:52 -0500 )edit