Ask Your Question
0

Issue while installing Puppet

asked 2016-05-31 18:34:03 -0500

PS gravatar image

I am trying to install the Open source project version of puppet .I am unable to accept certificate obtained from the agent. I have installed server and agent, server on Ubuntu 16.04 and agent on Windows 7

The error i am getting on the agent is -- Running Puppet agent on demand ... Error: Could not request certificate: getaddrinfo: No such host is known. Exiting; failed to retrieve certificate and waitforcert is disabled Press any key to continue . . .

on the server - puppet cert list $ puppet cert list -a + "sa-puppet-x11.crd.com" (SHA256) 1B:98:17:FD:08:57:A6:83:BA:96:19:E1:45:57:FD:D6:1C:28:9D:6C:5C:55:A9:91:80:01:3C:1E:FC:2A:81:76 (alt names: "DNS:puppet", "DNS:puppet.crd.com", "DNS:sa-puppet-x11.crd.com")

I do not have DB or any other component installed.

I have tried clearing and creating new certificates which does not seem to work --

my puppet.conf files are --

agent --

This file can be used to override the default puppet settings.

See the following links for more details on what settings are available:

- https://docs.puppetlabs.com/puppet/la...importantsettings.html

- https://docs.puppetlabs.com/puppet/la...aboutsettings.html

- https://docs.puppetlabs.com/puppet/la...filemain.html

- https://docs.puppetlabs.com/puppet/la...

[main] certname = pshenoy.crd.com server = sa-puppet-x11 environment = production runinterval = 1h [agent] report=true [master]

These are needed when the puppetmaster is run by passenger

and can safely be removed if webrick is used.

sslclientheader = SSLCLIENTSDN sslclientverifyheader = SSLCLIENTVERIFY

server -

[master] vardir = /opt/puppetlabs/server/data/puppetserver logdir = /var/log/puppetlabs/puppetserver rundir = /var/run/puppetlabs/puppetserver pidfile = /var/run/puppetlabs/puppetserver/puppetserver.pid codedir = /etc/puppetlabs/code dnsaltnames = puppetmaster01,puppetmaster01.example.com,puppet.example.com,sa-puppet-x11, sa-puppet-x11.crd.com storeconfigs = true environment_timeout = unlimited

[main] certname = sa-puppet-x11.crd.com server = sa-puppet-x11 environment = production "/etc/puppetlabs/puppet/puppet.conf" [readonly] 24L, 1002C

I have a feeling my config file has incorrect information.

I need assistance.

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-02 03:40:39 -0500

Tozz gravatar image

The layout in your question is broken, so its a bit difficult to read. However, I see that you have defined:

server = sa-puppet-x11

This is not a FQDN. Does this hostname resolve on your clients? I think not, because the error is quite clear:

Error: Could not request certificate: getaddrinfo: No such host is known.

This simply means your clients cannot resolve the defined server address.

edit flag offensive delete link more
0

answered 2016-06-02 16:49:08 -0500

DarylW gravatar image

That error usually means that your server name is specified incorrectly. you can either use the fully qualified domain name of your master, or if you manually add 'puppet' to your hosts file with the master's IP address.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-31 18:34:03 -0500

Seen: 380 times

Last updated: Jun 02 '16