Ask Your Question
0

Error: Could not connect to https://forgeapi.puppetlabs.com

asked 2016-06-13 18:16:43 -0500

puppetamateur gravatar image

updated 2016-06-13 18:18:25 -0500

Error: Could not connect to https://forgeapi.puppetlabs.com There was a network communications problem The error we caught said 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. - connect(2) for "forgeapi.puppetlabs.com" port 443' Check your network connection and try again

how can I fix this. when I ping forgeapi.puppetlabs.com

Pinging forge-api-fr.puppetlabs.com [23.236.57.230] with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 23.236.57.230:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
edit retag flag offensive close merge delete

Comments

Are you behind a proxy server? There is an http_proxy setting that can be applied, but there is no no_proxy option available.

DarylW gravatar imageDarylW ( 2016-06-13 21:36:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-06-14 11:36:39 -0500

puppetamateur gravatar image

I figured out the problem. The server was not connected to the internet. to install the library locally, just download the tar.gz file and puppet module install ~/xyz.tar.gz

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-13 18:16:43 -0500

Seen: 175 times

Last updated: Jun 14 '16