Ask Your Question
0

getaddressinfo name or service not known issue

asked 2016-06-14 13:22:45 -0500

Hi

I am having an issue when trying to serve files from the fileserver.

Below is an extract from my manifest.

        file { '/etc/pki/tls/certs/gd_bundle-g2-g1.crt' :
            ensure          => present,
            source          => $::hostname?{
                                    'myhost01' =>      'puppet://allCerts/uat/c664d20fd3442095.crt',
                                    'myhost02 =>      'puppet:///allCerts/prod/ad0e1531f99642c3.crt',
                                    'default'       =>      'null',
                            },

Which appears to be producing the following error

Error: /Stage[main]/Main/Node[myhost01]/File[/etc/pki/tls/certs/gd_bundle-g2-g1.crt]: Could not evaluate: Could not retrieve file metadata for puppet:///allCerts/prod/ad0e1531f99642c3.crt': getaddrinfo: Name or service not known

This appears to only be an issue on my RedHat 6.7 systems, I have other variations (7.2) that are functioning correcty

I've tried placing a entry in the hosts file to ensure that puppet is resolving correctly

Could anyone point me in the right direction here?

Thanks

edit retag flag offensive close merge delete

Comments

Is this a puppet agent run, or a puppet apply run? Have you set a server address in puppet.conf?

csharpsteen gravatar imagecsharpsteen ( 2016-06-14 14:19:15 -0500 )edit

This happens with the puppet agent run on specific hosts (RedHat 6.2) only. Yes the server address is set in puppet.conf When I run puppet agent -t --debug it appears the agent is not including puppet:/// instead the base url appears as https://allCerts:8140

mitchpsmith gravatar imagemitchpsmith ( 2016-06-14 14:42:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-14 15:03:01 -0500

Found the answer to my own question.

There was a typo in the config for the file source (A missing / )

'myhost01' =>
'puppet://allCerts/uat/c664d20fd3442095.crt',

should have been

'myhost01' =>
'puppet:///allCerts/uat/c664d20fd3442095.crt',

Moral of the story... always check for typos :(

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-06-14 13:22:45 -0500

Seen: 58 times

Last updated: Jun 14 '16