Ask Your Question
0

Is this a known bug? Server failing to start

asked 2016-06-17 10:06:51 -0600

EvanA gravatar image

Trying to install an initial puppet server and when I run:

systemctl start puppetsever

I receive this error:

Job for puppetserver.service failed because the control process exited with error code. See "systemctl status puppetserver.service" and "journalctl -xe" for details.

When I run:

systemctl status puppetserver.service

The output is:

● puppetserver.service - puppetserver Service

Loaded: loaded (/usr/lib/systemd/system/puppetserver.service; disabled; vendor preset: disabled)

Active: activating (start-post) since Fri 2016-06-17 10:35:18 EDT; 12s ago

Process: 28174 ExecStartPre=/usr/bin/install --directory --owner=puppet --group=puppet --mode=775 /var/run/puppetlabs/puppetserver (code=exited, status=0/SUCCESS)

Main PID: 28175 (java); : 28176 (bash)

CGroup: /system.slice/puppetserver.service

       ├─28175 /usr/bin/java -Xms2g -Xmx2g -XX:MaxPermSize=256m -XX:OnOutOfMemoryError=kill -9 %p -Djava.security.egd=/dev/urandom -cp /opt/puppetlabs/server/apps/puppetserver/puppet-server-release.jar clojure.main -m puppetlabs.t...
       └─control
         ├─28176 /bin/bash /opt/puppetlabs/server/apps/puppetserver/ezbake-functions.sh wait_for_app
         └─28237 sleep 1

Jun 17 10:35:18 dv00012 systemd[1]: puppetserver.service holdoff time over, scheduling restart.

Jun 17 10:35:18 dv00012 systemd[1]: Starting puppetserver Service...

Jun 17 10:35:18 dv00012 java[28175]: OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

I've been trying to find solutions but there don't seem to be any.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-14 07:33:39 -0600

iaingblack gravatar image

updated 2016-07-29 10:48:14 -0600

I had the same issue on CentOS7 using Foreman 1.12. Turns out I had to just give my VM more RAM. 1.5GB didnt start it, 2.5GB didnt start it, but 4GB did, The 2GB memory parameter for java needs the full 2GB available I think so riding close to this edge isn't going to work.

If anyone else is using foreman and getting error ERF12-2749 then the problem could be that the puppetserver had not started and foreman-proxy cannot reach it over SSL connction, not that the SSL certs are wrong etc...

ADDENDUM;

This wasn't the real problem as the above worked on CentOS 7 but not Redhat 7. This is two things. A bootstrap location not found (no idea why) and an issue with /tmp being set as noexec which stops puppetserver using it as a temp lcoation for scripts.

Amend /etc/sysconfig/puppetserver

BOOTSTRAP_CONFIG="/etc/puppetlabs/puppetserver/bootstrap.cfg,/etc/puppetlabs/puppetserver/services.d/,/opt/puppetlabs/server/apps/puppetserver/config/services.d/"

TO

BOOTSTRAP_CONFIG="/etc/puppetlabs/puppetserver/bootstrap.cfg,/etc/puppetlabs/puppetserver/services.d/"

https://github.com/puppetlabs/puppets...

Then, run this command to make /tmp execable

mount -o remount,exec /tmp

Then restart the service

sudo systemctl restart puppetserver.service

Not sure how to make this survive a reboot, adding exec in /etc/fstab after bind like this "/tmp /var/tmp none bind,exec 0 0" doesnt seem to work). If aynone can fix this let me know!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-17 10:06:51 -0600

Seen: 1,496 times

Last updated: Jul 29 '16