Ask Your Question
0

i have successfully installed puppet on master VM but i am unable to install the same on agent VM(getting below error) ??

asked 2016-07-18 22:50:44 -0500

rathods gravatar image

Hello Sir,

i have successfully installed puppet on master VM but i am unable to install the same on agent VM(getting below error)

OS : Linux redhat Puppet version : 3.8

Error: when i am doing the installation using answers file: ?? Install puppet master? [y/N] n ?? Puppet master hostname to connect to? [Default: puppet] puppet ?? The installer couldnât reach the puppet master server at puppet. If this server name is correct, please check your DNS configuration to ensure the puppet master node can be reached by name, and make sure your firewall settings allow traffic on port 8140. Enter ârâ if you need to re-enter the puppet masterâs name; otherwise, enter âcâ to continue. [c/r] !! ERROR: Could not find response for above question in answer file. (Variable needed: qcontinueorreentermaster_hostname)

Could you please help me on this?

thanks, Saikrishna Rathod Hyderabad

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-20 03:51:33 -0500

updated 2016-07-20 03:53:11 -0500

Add the puppet server host entry to the host file so that your puppet agent can know where your puppet server is. Add entry of puppet server in client sever and puppet client ip in puppet server in /etc/hosts file For puppet client as like below-

<ip_address> puppet

edit flag offensive delete link more

Comments

Her is my host file in agent server, but i am still facing the same [root@agent ~]# more /etc/hosts 192.168.181.132 agent.com agent 192.168.181.132 agent 192.168.181.133 puppet.com puppet 127.0.0.1 localhost.localdomain localhost ::1 agent localhost6.localdomain6 localho

rathods gravatar imagerathods ( 2016-07-20 20:48:08 -0500 )edit

why this puppet.com? And you have declared puppet twice - is it running on same vm/machine? Then just add 127.0.0.1 puppet And remove other puppet related entries and if running on different server then replace the localhost IP with actual IP

scm_questor gravatar imagescm_questor ( 2016-07-20 23:01:15 -0500 )edit

192.168.181.133 puppet 192.168.181.132 agent here is the latest hosts file on agent/master vm with only agent and master details. but still getting same.

rathods gravatar imagerathods ( 2016-07-20 23:58:40 -0500 )edit

sorry mate - i was away for week & couldn't reply. I thought it has been resolved If you r still getting the same error, please can you check ur answer file as it seems that its not getting proper response "Enter ârâ if you need to re-enter the puppet masterâs name; otherwise, enter âcâ to continue"

scm_questor gravatar imagescm_questor ( 2016-08-02 13:21:46 -0500 )edit

also please check the connectivity for both the servers with ping,ssh

scm_questor gravatar imagescm_questor ( 2016-08-02 13:22:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-18 22:50:44 -0500

Seen: 36 times

Last updated: Jul 20 '16