logdir config setting doesn't seem to work

asked 2016-07-22 13:03:24 -0600

Tundra gravatar image

Hey everybody, So I'm trying to get the puppet agent to stop logging to syslog and instead log to /var/log/puppetlabs/puppet (which supposedly is the default but it never logs there). I tried running the agent using --logdir:

puppet agent -t --logdir /var/log/puppetlabs/puppet/ --log_level debug

This did not log to the directory I specified and still logged to syslog. In the debug output it even says that the logdir is set to what I want:

Debug: Using settings: adding file resource 'logdir': 'File[/var/log/puppetlabs/puppet]{:path=>"/var/log/puppetlabs/puppet", :mode=>"750", :owner=>"puppet", :group=>"puppet", :ensure=>:directory, :loglevel=>:debug, :links=>:follow, :backup=>false}'

I then tried adding the parameter in the puppet.conf file which also didn't work:

[agent]
logdir = /var/log/puppetlabs/puppet

I checked the permissions on the directories and they are all owned by the puppet user so I don't think it is that kind of issue. This seems like it should be simple, what am I doing wrong? Thanks!

edit retag flag offensive close merge delete

Comments

Hello. Have you find the solution? I am facing a similar problem.

Edely gravatar imageEdely ( 2016-09-16 09:03:05 -0600 )edit

Hello. I'm facing that issue too. Did you manage to fix it ?

craymore gravatar imagecraymore ( 2016-12-15 09:04:50 -0600 )edit