Error: Could not run: Could not create PID file: /var/run/puppet/master.pid on puppet master version 3.8.7. variables seem correct.

asked 2016-07-22 17:43:42 -0500

Sanjib gravatar image

updated 2016-07-25 00:21:58 -0500

ramindk gravatar image

Install a puppet master on puppet 3.8.7. I keep getting the error list. My /etc/hosts look like this.

ip address   hostame

Puppet conf file looks like this.

 certname = puppet master host name
     server = puppet master host name
     environment = production
     runinterval = 1h
     strict_variables = true

I have a box in production that I am mirroring so I must be doing something wrong. I copied the hosts and conf file from production.

I tried using the example on the forum but no luck since they asked the same question.

edit retag flag offensive close merge delete

Comments

Check that /var file system isn't mounted NOEXEC. On some of my servers, PCI requires that /var be NOEXEC and puppet complains. You may have something similar going on.

bschonecker gravatar imagebschonecker ( 2016-07-24 08:26:30 -0500 )edit

Supply details like: OS (version,kernel etc.) Also, is /var/run symlinked to /run ? (ls -lad /var/run) If not, you have a static /var/run dir which works, but you've to set the permissions. (pe-puppet.pe-puppet)

FranzCC gravatar imageFranzCC ( 2016-07-25 00:57:50 -0500 )edit