Ask Your Question

Problem to generate modules

asked 2016-07-25 21:14:56 -0600

Marcos Lira gravatar image

Hi Guys, I'm unable to generate modules, i'm getting the following error:

root@marcos-VirtualBox:/etc/puppetlabs/code/modules# puppet module generate --skip-interview puppet
Error: Could not generate directory "puppet", you must specify a dash-separated username and module name.
Error: Try 'puppet help module generate' for usage

Thanks for any help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-07-26 00:58:38 -0600

lupin gravatar image

updated 2016-07-26 13:28:28 -0600


As the error message says you need to name a module with a dash(-) on it. E.g

puppet module generate --skip-interview xy-modulename
edit flag offensive delete link more


Thank you, it worked that way. At first I got confused because I was using a dash-separated name but with two dashes, like "puppet-mod-apache". But now i got. It has to have only one dash.

Marcos Lira gravatar imageMarcos Lira ( 2016-07-26 18:57:03 -0600 )edit

You'll find that puppet (and ruby) isn't friendly to dashes.. they break variables and things. you also can't have a dash in your puppet environments. We have a bunch of "tr - _" style transformations littered all over the place to make things work in puppet, as our team loves their dashes

DarylW gravatar imageDarylW ( 2016-07-27 16:13:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-07-25 21:14:56 -0600

Seen: 994 times

Last updated: Jul 26 '16