Ask Your Question
0

Getting error when giving this command "puppet resource service puppet ensure=running enable=true"

asked 2016-07-28 08:35:36 -0600

swethak123 gravatar image

Output of this command:

Error: Could not start Service: Execution of '/sbin/service puppet start' returned 1: puppet: unrecognized service Wrapped exception: Execution of '/sbin/service puppet start' returned 1: puppet: unrecognized service Error: /Service/ensure: change from stopped to running failed: Could not start Service: Execution of '/sbin/service puppet start' returned 1: puppet: unrecognized service service { 'puppet': enspuppet resource service puppet ensure=running enable=trueure => 'stopped', enable => 'false', }

Could you please help me on this

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-28 10:48:48 -0600

mike.r gravatar image

check if theres a puppet service in /etc/init.d

edit flag offensive delete link more

Comments

Hi Mike, No, I didn't find any puppet service in /etc/init.d/. I can see only pe-puppet. I didn't know what could be the reason Thanks

swethak123 gravatar imageswethak123 ( 2016-07-28 11:07:42 -0600 )edit

are you using Puppet Enterprise or Puppet Opensource? Which version (3.x or 4.x?)

DarylW gravatar imageDarylW ( 2016-07-29 08:14:34 -0600 )edit

I am using Puppet Enterprise Version 3.x Thanks

swethak123 gravatar imageswethak123 ( 2016-07-29 08:36:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-28 08:35:36 -0600

Seen: 96 times

Last updated: Jul 28 '16