How can I update cisco_node_utils gem to 1.3.1 using the code at github?

asked 2016-08-01 08:59:31 -0500

After I upgraded the puppetlabs-ciscopuppet module to v1.3.2, puppet apply failed with the following message on a puppet agent:

root@n93120tx#puppet agent -t
Warning: Setting ignorecache is deprecated.
   (at /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/settings.rb:1144:in `issue_deprecation_warning')
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for n93120tx-03
Info: Applying configuration version '1470052318'
Error: Failed to apply catalog: undefined method `pvlan_association' for #<Cisco::Vlan:0x00000003cb28b8 @vlan_id="1">

I noticed that 'cisconodeutils v1.3.0' gem which I use currently does not include the method of pvlan_association. I also noticed that the gem of v1.3.1 includes the method. So, I tried to upgrade it, but I was not able to do so with the command of 'gem install' because the latest version on remote gem at 'https://rubygems.org' is 1.3.0. How can I upgrade it using the code at github?

edit retag flag offensive close merge delete