Ask Your Question
0

Installing puppet 3.8.7 issue

asked 2016-08-01 11:38:02 -0500

Snirka gravatar image

Hello! I'm trying to install puppet-server 3.8.7. The problem is that the puppet-server automatically requires puppet, that requires puppet-agent, who supplies me only the newest version that fits puppet 4.x only (puppet-agent-1.5.2). The "yum install puppet-server" Failed . What can i do?

edit retag flag offensive close merge delete

Comments

I think you would have to create a repo that points to a location that contains the version of puppet you want to use. For example, https://yum.puppetlabs.com/el/6.0/products/x86_64/

Snoopy_ gravatar imageSnoopy_ ( 2016-08-08 14:34:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-01 12:01:19 -0500

wdcapl gravatar image

Download packets manualy and install them.

edit flag offensive delete link more

Comments

I can't find the correct packages, because each package asks for the latest package of it's dependency. I've been trying to find which puppet-agent version i need that fits puppet-server3.8.7 and didnt find yet.

Snirka gravatar imageSnirka ( 2016-08-02 02:01:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-01 11:38:02 -0500

Seen: 44 times

Last updated: Aug 01 '16