Ask Your Question
0

Apache can't start after installing passenger

asked 2016-08-02 13:15:43 -0600

Lior gravatar image

updated 2016-08-02 13:15:58 -0600

I followed the installation steps on puppet documentation page but apache (httpd) can't start I'm using puppet 3.8.7

for some reason apache can't parse puppet.conf file

root@ip-172-31-44-179 conf.d]# service httpd start Starting httpd: Syntax error on line 1 of /etc/httpd/conf.d/puppet.conf: Invalid command '[main]', perhaps misspelled or defined by a module not included in the server configuration

Any help will be appreciated

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-03 14:34:01 -0600

Snirka gravatar image

updated 2016-08-03 14:34:16 -0600

You shouldn't put the puppet.conf in this directory. If you successfuly installed your passenger you should edit this file and put it in the /etc/httpd/conf.d: (https://docs.puppet.com/puppet/3.8/re...) under "example vhost configuration"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-02 13:15:43 -0600

Seen: 37 times

Last updated: Aug 03 '16