Ask Your Question
0

puppet run as non root user service account

asked 2016-08-04 04:35:06 -0500

venky gravatar image

confdir location for the puppet is for root user Unix/Linux: /etc/puppetlabs/puppet – Non-root user: ~/.puppetlabs/etc/puppet I have service account which is single login across multiple machines, in this case i want to run puppet with this account. But the ~ home location will be same across multiple machine which is shared path .

With service account still i want to use /etc/puppetlabs/puppet as conf directory.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-08-04 11:42:43 -0500

DarylW gravatar image

That is just the default location that is created for a non-root user. You can specify the actual location either when you run the command, or by setting it in your puppet.conf file. It may not be an issue (the ssl information is stored on a per hostname basis, and they shouldn't conflict. You'll get all of the machines reports accumulating, so it may be undesirable from a "does this data all belong on the shared directory" point of view.

edit flag offensive delete link more

Comments

Can you give an example ? As non root user i tried config=/etc/puppetlabs/puppet but giving permission errors of dir /var/opt/lib/puppet

venky gravatar imagevenky ( 2016-08-05 00:21:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-08-04 04:35:06 -0500

Seen: 34 times

Last updated: Aug 04 '16