Ask Your Question
0

Disable --detailed-exitcodes

asked 2016-08-04 06:03:50 -0500

venky gravatar image

When i run $puppet agetnt -t the exit code is 2

0: The run succeeded with no changes or failures; the system was already in the desired state. 1: The run failed, or wasn't attempted due to another run already in progress. 2: The run succeeded, and some resources were changed. 4: The run succeeded, and some resources failed. 6: The run succeeded, and included both changes and failures.

But i am using bamboo tool which works like if return code is non-zore than deployment failure.

--test Enable the most common options used for testing. These are 'onetime', 'verbose', 'no-daemonize', 'no-usecacheonfailure', 'detailed-exitcodes', 'no-splay', and 'show_diff'.

Reference: https://docs.puppet.com/puppet/latest...

So how can i disable --detailed-exitcodes

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-15 20:38:20 -0500

trenta gravatar image

updated 2018-05-16 01:46:53 -0500

I was having the same issue with puppet bolt and found the --test reference you did. So can't you just have the puppet agent run using all the same options as test but without the detailed exitcodes option?

e.g. puppet agent --onetime --verbose --no-daemonize --no-usecacheonfailure --no-splay --show_diff

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-08-04 06:03:50 -0500

Seen: 335 times

Last updated: May 16