Notice: /Stage[main]/Puppet_enterprise::Mcollective::Server::Facter/File[/opt/puppetlabs/puppet/bin/refresh-mcollective-metadata]/mode: mode changed '0755' to '0775'

asked 2016-08-04 13:13:58 -0500

apark gravatar image

Hi,

I noticed that a puppet agent installs a cron job that uses the script /opt/puppetlabs/puppet/bin/refresh-mcollective-metadata. I want this to be permission 0755 but whenever I do that I see the following in the next puppet agent run.

Notice: /Stage[main]/Puppet_enterprise::Mcollective::Server::Facter/File[/opt/puppetlabs/puppet/bin/refresh-mcollective-metadata]/mode: mode changed '0755' to '0775'

Is there a way to change the default value?

Please help,

Thanks

edit retag flag offensive close merge delete