Ask Your Question
0

mCollective - ssl+stomp giving Unexpected Error on connection - es1_oldrecv: receive failed Stomp::Error::ReceiveTimeout [closed]

asked 2016-08-23 10:32:49 -0500

SKasai gravatar image

Hi,

We are building a new windows image and when we tried putting on the mCollective client on the system with a little kludging of getting Ruby 1.9.3 installed (as it is now up to 2.1.3), we have it installed and the service running, however, when we try to do mco ping or any form of discovery of the system, it does not respond.

The mcollective.log we get is this:

http://pastebin.com/BeP8YNdH

The end result is usually:

E, [2016-08-23T07:45:08.633946 #1868] ERROR -- : activemq.rb Unexpected error on connection stomp+ssl://mcollective@puppet<domain>:<port>: es1_oldrecv: receive failed: Stomp::Error::ReceiveTimeout I, [2016-08-23T07:45:08.633946 #1868] INFO -- : activemq.rb Estblishing SSL session with stomp+ssl://mcollective@puppet<domain>:<port> I, [2016-08-23T07:45:08.903946 #1868] INFO -- : activemq.rb SSL session established with stomp+ssl://mcollective@puppet<domain>:<port> I, [2016-08-23T07:45:08.913946 #1868] INFO -- : activemq.rb Conncted to stomp+ssl://mcollective@puppet<domain>:<port>

We even copied the mcollective files from a working system, still resulting in the same response.

Any suggestions?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SKasai
close date 2016-08-23 17:07:52.763374

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-23 13:09:55 -0500

SKasai gravatar image

After speaking with the IRC group, it looks like it was an issue with the stomp version and MCollective we were using.

For edification purposes, I am on an Open Source version of Puppet (3.8.7) and have not go over to the 4.x version yet. Mcollective for Windows is not quite part of the client until Puppet Version 4.x. Since we can't use the 4.x Puppet Agents, we were using the Marco MCollective installer.

This uses Ruby 1.9.3, and stomp version 1.3.4. Newer Rubyinstallers won't work and makes the mCollective installer not work properly, and doing gem installs for stomp will either go with the 1.2 (Which won't cover SSL support due to SSLv3 issues and is default for the old mCollective installer) or go to 1.4.1-1.4.3 stomps (Which give the es1_oldrecv error, which is not documented anywhere)

If users get this issue, they need to remove the stomp-1.4.1 and up and only leave the stomp-1.3.4 in order for it to work.

If you have Puppet Modules that are updating mcollective ruby gems for windows and using the old mcollective installer, and not on Puppet 4, you will need to make your module only do the ruby gem update once stomp-1.3.4 is there, otherwise, this will break your 3.8.x mcollective implementation.

The recommended Puppet Open Source is to upgrade to 4.0 when possible, if not, do as above.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2016-08-23 10:32:49 -0500

Seen: 176 times

Last updated: Aug 23 '16