Ask Your Question

CentOS agent version

asked 2016-08-24 06:03:05 -0600

Amiram gravatar image


I'm running PuppetMaster 3.4.3 and i now want to install agents on my CentOs servers. I have a closed network so I'm not connected to the internet, in order to install the agents i have downloaded the puppetlabs yum el repo and i can install the puppet-agent on my CentOS servers.

But, the oldest version that i have in that repo is 4.0.0 which can't work with the master version that I'm running. I don't want to upgrade the master version.

Do you have any idea where i can download puppet agent older than (lets say) 3 with all the relevant dependence.

P.S I'm running CentOs 6.5 and 6.7.

Thank you, Amiram

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2016-08-25 02:45:41 -0600

Mr_Sharma gravatar image

For my version following works and able to get the agent package which is available on puppet master:

  1. Executing curl command from your agent: curl -k https://puppetmaster:8140/packages/cu... | sudo bash
  2. Getting package directly from server at path: /opt/puppetlabs/server/data/packages/public

Let's try if it works for you.

edit flag offensive delete link more

answered 2016-08-25 06:18:33 -0600

Amiram gravatar image

updated 2016-08-25 06:18:57 -0600


Thank you for the quick response. But unfortunately i don't have this folder at my master (i don't have any folder named puppetlabs - only puppet)

Is it possible that there is no agent version older than 4.0.0 for CentOs.

Thank you, Amiram

edit flag offensive delete link more

answered 2016-08-27 09:32:42 -0600

natemccurdy gravatar image

Can you share with us exactly what YUM repo you added? It sounds like you added the PC1 repo, which only has Puppet version 4 and up.

Take a look at this page for more details

Basically, as of Puppet version 4, everything that Puppet needs (Ruby, Facter, Hiera, etc...) has been bundled together into a package called puppet-agent and that is what is in the PC1 repo. If you want the older un-bundled version of Puppet (everything less than 4), you should use the older repository, Documented here

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-08-24 06:03:05 -0600

Seen: 69 times

Last updated: Aug 27 '16